Get_prices fails when getting data from multiple history databases, if no prices exist in one

I’m using the usstock-minute database together with a supplementary/secondary minute history database populated via IB. The reason for this is to account for gaps in data within the usstock-minute database, where IB often has any missing data.

Between the two data sources I’ve been able to get all the data I need, but I’m now running into errors when I attempt to get prices as below if prices exist in one table, but not the other.

get_prices(["usstock-minute", "usstock-minute-supplementary"], start_date="2018-12-10", end_date="2018-12-10", sids=['FIBBG00RBFBL50'], fields=["Open","High","Low","Close", "Volume"])

Everything is fine if data exist in both databases. But if data exist in one but not the other, I get the following error:

HTTPError: ('400 Client Error: BAD REQUEST for url: http://houston/zipline/bundles/data/usstock-minute.csv?start_date=2018-12-10&end_date=2018-12-10&sids=FIBBG00RBFBL50&fields=High&fields=Low&fields=Close&fields=Open&fields=Volume', {'status': 'error', 'msg': 'no minute data match the query parameters'})

In practice, I don’t think this will be much of an issue for me personally as I’ll mainly be getting a universe of securities, and so data will likely always exist in both tables for the query as a whole, but just reporting here in case this is a bug.

It should only complain if none of the databases have data, so yes that’s a bug.

Yay! I finally found a real bug lol.

This issue is fixed in version 2.5.0.

This topic was automatically closed after 4 days. New replies are no longer allowed.