Fundamental database does not update on local instance after S3 push pull

I run two instances, one on the cloud for data downloading and one locally for analysis.

If I run this command on my cloud instance it shows the data I have

quantrocket fundamental estimates 'EPS' -u 'sfb' -s '2014-01-01' -e '2017-01-01'

I then

quantrocket db s3push 'fundamental'

On the cloud instance and then

quantrocket db s3pull 'fundamental' -f

on the local instance.

After waiting for the download to finish I run the original command on the local instance

quantrocket fundamental estimates 'EPS' -u 'sfb' -s '2014-01-01' -e '2017-01-01'

msg: No estimates match the query parameters
status: error

Am I missing something?

It might be due to query caching. Fundamental query results are cached for 24 hours and the cached results are returned if subsequent queries use exactly the same parameters. Cached files are automatically removed when you collect new fundamental data but currently the cache doesn’t get cleared when you pull down a new fundamental db from S3. That’s an oversight and we’ll make an internal ticket to fix that.

As a workaround, you can vary the date range by a day or re-create the fundamental container (not just restart it) to clear the cached files.

1 Like

Resolved via a new warning.

This topic was automatically closed after 33 hours. New replies are no longer allowed.