Zipline logging stopped working

For some reason, my zipline logging to the flightlog seems to have stopped working. I have tried restarting the containers and reloading Docker many times but I just don't seem to be able to fix it, including executing: docker-compose -p quantrocket up -d --force-recreate

example run in jupyter:

progress ='D',
start_date= "2021-01-01",
end_date= "2021-11-30",
capital_base= 1000000,

The backtest runs fine and any ziline print statements do print to the flightlog detail window. The backtest progress bar and information are not being logged anymore!

I am not sure what happened as this was working fine. After a Docker restarted it stopped working. I don't see any specific errors in flightlog to report regarding this not working.

Another strange thing I have noticed the names of modules have changed from using the underscore to hyphen !

quantrocket-houston-1| - - [02/Dec/2021:07:01:56 +0000] "GET /quantrocket-ibg1-1/gateway HTTP/1.1" 404 0 "-" "python-requests/2.25.1"
quantrocket-houston-1| - - [02/Dec/2021:07:01:56 +0000] "GET /ibgrouter/gateways?status=running HTTP/1.1" 200 3 "-" "-"
quantrocket-houston-1| - - [02/Dec/2021:07:01:57 +0000] "POST /zipline/backtests/LongShortStratProdRefe?data_frequency=daily&capital_base=1000000&bundle=usstock-1d-bundle&start_date=2021-10-01&end_date=2021-11-30&progress=D HTTP/1.1" 200 1293657 "-" "-"
quantrocket-blotter-1|recycling spooler after 90 tasks
quantrocket-blotter-1|OOOPS the spooler is no more...trying respawn...
quantrocket-blotter-1|spawned the uWSGI spooler on dir /var/tmp/uwsgi/spool with pid 43
quantrocket-houston-1| - - [02/Dec/2021:07:02:17 +0000] "GET /master/securities.csv?vendors=ibkr&fields=ibkr_ConId HTTP/1.1" 400 137 "-" "-"
quantrocket-houston-1| - - [02/Dec/2021:07:02:17 +0000] "GET /master/securities.csv?vendors=alpaca&fields=alpaca_AssetId HTTP/1.1" 400 139 "-" "-"
quantrocket-houston-1| - - [02/Dec/2021:07:02:17 +0000] "GET /account/balances.csv?latest=True&fields=Account&fields=Broker HTTP/1.1" 200 79 "-" "-"
quantrocket-houston-1| - - [02/Dec/2021:07:02:17 +0000] "GET /quantrocket-ibg1-1/gateway HTTP/1.1" 404 0 "-" "python-requests/2.25.1"
quantrocket-houston-1| - - [02/Dec/2021:07:02:17 +0000] "GET /ibgrouter/gateways?status=running HTTP/1.1" 200 3 "-" "-"
quantrocket-account-1|waiting until ECB's next expected 4PM CET update to

Any help is appreciated.

The switch from underscores to hyphens is the likely culprit. Docker Desktop now ships with Docker Compose v2, which uses hyphens, but QuantRocket doesn't yet support that (the next version will). The installation docs were recently updated and contain the solution, which is to disable Docker Compose v2:

docker-compose disable-v2

Then take down your deployment and re-create it:

docker-compose down
docker-compose up -d

This will result in underscores which I would hope will resolve the problem.

That worked! Thanks Brian.