Private cloud SSL certificate problem

I am attempting to set quantrocket up as a private cloud deployment. Unfortunately, it fails because Let’s Encrypt only issues SSL certificates for public domains/ip addresses, and my internal cloud is on a private address space. Since I don’t need SSL to connect, can I disable SSL? Or, failing that, can I self-sign rather than go via Let’s Encrypt?

I’d really like to avoid having to open up a port on the firewall just so I can have a public domain/ip to access my internal quantrocket instance.

To run QuantRocket in a private cloud:

  • Launch your cloud instance and SSH onto it
  • Follow the Linux tutorial to install QuantRocket on the cloud instance
  • Instead of going to http://localhost:1969, go to http://<private_ip_of_instance>:1969

Thanks Brian. That’s what I did first but got the errors I mentioned in the other posts when I tried to do the examples in the QuickStart when connecting via http://<private_ip_of_instance>:1969. I assumed it was a problem with URL redirects so tried the cloud install. Now that those other errors have been resolved, the issue is moot.